Browser requirements

When using Online banking, always make sure that you’re using the latest version of your web browser. This is important because older versions of your browser are always at increased risk of causing issues.

List of supporting browsers:

Microsoft Windows
• Mozilla Firefox (the latest version)
• Google Chrome (the latest version)
• Microsoft EDGE (the latest version)

Apple MacOS
• Mozilla Firefox (the latest version)
• Google Chrome (the latest version)
• Apple Safari (the latest version)

Was this answer helpful?

Do you have any other questions?